Jump to content

shalesharkpants

kangertech evod tank firing but not hitting

Recommended Posts

I bought a kangertech evod tank a couple months ago and I wasn't having any issues. I bought it because nobody had new wicks for my old tank so in a rush I bought this one. Anyways, it was working fine until a few days ago it wasn't hitting very good, I thought I needed a new wick since it was getting to be about that time. I bought a new wick and I was still having the issue but within an hour it stopped hitting all together. It is firing though, I can hear it and it's not gurgling. It sounds perfect, I just can't figure out why I can't get a hit. Both of my batteries are vision spinners, one is just a newer version in case that's relevant. Any help would be appreciated, I can't find anything online. Thanks!

Share this post


Link to post
Share on other sites

Your center pin might have gotten pushed down and is no longer making contact with the atomizer in your EVOD. Check out this video, even though this is an eGo battery, the premise is the same. Hope that helps!

Share this post


Link to post
Share on other sites

I was just about to say that Tam... beat me to it. Happen to me once, and was because some of the e-liquid went into the gap between the battery and the tank, and it offset the pin position.

Share this post


Link to post
Share on other sites

The EVOD tank uses the standard Kanger Pro-Tank single-coils, which are available... everywhere... The EVOD2 and EVOD-Glass use dual-coils (also available everywhere).

One thing to consider, though, is that you may actually have an MT3 tank, sold as an EVOD-style, which requires a different coil.  The easy way to tell is to look at the base of the tank.  The EVOD base is smooth, and the MT3-style are knurled (and shorter).

Chances are the battery pin has been pushed down, but just as likely that you just have a dud coil.  The good news is that you rarely get a bad one if they are authentic coils.  In the last year and a half of vaping, I've found only one dud, and a couple that only lasted through one tank-full of juice.  The vast majority of them last for weeks.

BTW, Welcome to VT!

Share this post


Link to post
Share on other sites

I should have said this, my other tank works with it but it needs a new wick and it's cheap so it's not the best. I also have two batteries and it doesn't work on either one, I thought it was the battery pin because I've had that issue before. I should have explained it better, when I hit the button on the battery you can hear it fizzle like it's fine but you just can't get any vapor. 

Share this post


Link to post
Share on other sites

Check you airholes are not gunked up and are clear

Make sure the threads of the battery are not blocking the airholes.  

 

Pull the coil and blow thru it and make sure its clear. 

Make sure the chimney section including the tip is clear.

Edited by Bebop

Share this post


Link to post
Share on other sites

Tam was right in my case..my tank stopped working with my battery, but both pieces worked with another brand (evod tank worked with different battery, and evod battery worked with different tank, but both evod battery & tank wouldn't work together).. I was so frustrated but finally found this post online and watched the video tam posted--SAVED my tank and battery from being chucked lol..so THANKYOU  tam and vaportalk! :)

Share this post


Link to post
Share on other sites

Tam was right in my case..my tank stopped working with my battery, but both pieces worked with another brand (evod tank worked with different battery, and evod battery worked with different tank, but both evod battery & tank wouldn't work together).. I was so frustrated but finally found this post online and watched the video tam posted--SAVED my tank and battery from being chucked lol..so THANKYOU  tam and vaportalk! :)

That's great that you got your battery and tank working again. Happy vaping!  :)

Edited by Tam

Share this post


Link to post
Share on other sites

I tried the great youtube to pull the pushpin up a bit. Still not firing, just heating up so it's hot to the touch, and I have to listen for the crackle.  any other ideas?

Share this post


Link to post
Share on other sites
Posted (edited)

The wick is what soaks up the juice then the coil heats it into vapor

Edited by cany

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Vapor Talk Forum

Vapor Talk is a worldwide retailer of electronic cigarettes, e liquids, vape mods & more! Our Store and Online Vape Forum has served over 1 million+ Users since 2008.

Locations

Vapor Talk North America
41419 Pear Street, Murrieta, CA 92562
Phone: 1-888-315-VAPOR

Vapor Talk China
Locations: Beijing, Qingdao
Phone: +88-1-400-698-2209
×
×
  • Create New...