Jump to content

WellerJD88

VT Member
  • Content Count

    6
  • Joined

  • Last visited

  • Days Won

    1

WellerJD88 last won the day on June 10 2017

WellerJD88 had the most liked content!

About WellerJD88

  • Rank
    VT Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Can't you discharge higher amps in parallel? Thought series you add voltage, parallel you and amperage.
  2. Picked up Limitless Mod Co's new Pulse with some Solace Vanilla Bean with the new salt nic. Sent from my iPhone using The Vapor Talk mobile app
  3. Have you cleaned your tank? I have had similar issue but when changing coils I make sure to clean the bottom where the coil makes contact and the top. Use a Q-Tip to clean out the tube real well. Might have some residue in there that you still getting. Sent from my iPhone using Tapatalk
  4. All of the coils I have gotten for the Big/BabyBeast and the TFV-12 are all stainless. Have used both in temp and watt. Sent from my iPhone using Tapatalk
  5. Well I think I found the issue. I don't think my atty was tightened enough. Sent from my iPhone using The Vapor Talk mobile app
  6. Just got this mod and I can only get a few good pulls before it just won't fire any more. Using two Brillipower IMR18650's rated for 3100MAH and max 40A. My build is two five wrap Alien wire running about .3 ohms in Wismec Indestructible. The light gives about 10 slow blinks when pressing fire button followed by several fast blinks then goes off. Device does not shut down, just won't fire. Any tips suggestions? Sent from my iPhone using The Vapor Talk mobile app
×
×
  • Create New...