Jump to content

Panzer by mcv Philippines not working


iamtyler719

Recommended Posts

Hello! I recently got the panzer from a friend and it's not firing at all and I'm not sure why. I'm using a goon rda with an 18650 battery and no matter what I do it will not fire. I've tried it with a few different RDAs and it won't work with any of them. The battery and the rda works with all of my other mods, none of which are RDAs. What could be causing this to happen? I've tried adjusting the 510 pin in the top inside of the mod and the pin on the rda. Any help will be greatly appreciated! 80dabd675b7126b3262587bd0d592b34.jpg42a21248781ab2e3e6b390b62420ec2a.jpgb459cde0e9f5a27e201be01b61093826.jpge026e07f04071816fe4b9826dad5de64.jpg1ab0dd33ef328293d078d15da34956cd.jpg14af4adcf8e27b5e244ca561b2ba50a5.jpg2a87f1e2b98a06b38a4ae58edfd80552.jpg

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...