Jump to content

Search the Community

Showing results for tags 'x2o pen'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Vapor Talk!
    • Forum Announcements & Rules
    • Site Feedback, Help & Requests
    • Vapor Talk Store Discussion
    • Click to Visit the Vapor Talk Store
  • General e Cigarette Forum
    • New Vapers Forum
    • General Vaping Discussion
    • General E-Liquid Discussion
    • Health & Safety
    • Help It Broke! - eCig Technical Issues
    • Latest Vaping Products
  • DIY E-Liquid
    • DIY e Liquid - General Discussion
    • DIY e Liquid Recipes
    • eLiquid Safety
  • Modding & Technical
    • Modders Forum
    • APV and Mods Discussion
    • Tanks, Clearomizers & Drop in Coils
    • Rebuildable Atomizer Systems
    • Member Tutorials
  • Vape News, Events & Campaigning
    • General Vape News
    • Vaping Legislation & Regulation News
    • Vape Meets and Conventions
    • Vape Agenda.com
  • e Cigarette Reviews
    • e Cigarette Hardware Reviews
    • e Liquid Reviews
    • Vape Store & Supplier Reviews
  • The Lounge
    • The Vape Lounge - Off Topic Chat
    • Polls and Questionnaires
    • The VIP Room
  • Founders Club's Ask the Founder
  • Founders Club's What's New at Vapor Talk

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Skype


Location


Interests

Found 1 result

  1. OK, so I got an x2o starter kit a while ago and I didn't really start using it until lately. Anyhow, the plastic mouthpiece ended up breaking which was fine since I had lost the charger and was going to the vape shop to replace it and could grab the piece while I was there. It was working great until I charged the damn thing today. The guy at the store said that it would work with my battery even though I have an x2o battery and the charger is a kangertech. Now when I go to press my button with my tank/mouthpiece screwed in, it blinks three times as if its not charged, but when I take out the mouthpiece and press the button it lights up like its supposed to. Did I mess my battery up by trusting the guy at the shop, or could it be something else is wrong? The mouthpiece is new as well, but it was working perfectly until I charged it, so I don't think that's the issue.

Vapor Talk Forum

Vapor Talk is a worldwide retailer of electronic cigarettes, e liquids, vape mods & more! Our Store and Online Vape Forum has served over 1 million+ Users since 2008.

Locations

Vapor Talk North America
41419 Pear Street, Murrieta, CA 92562
Phone: 1-888-315-VAPOR

Vapor Talk China
Locations: Beijing, Qingdao
Phone: +88-1-400-698-2209
×