Jump to content
Sign in to follow this  
ciggrettesarebad

Aspire Nautilius AIO WONT FIRE

Recommended Posts

Hello am new to this i bought my aspire aio 2 months ago and i was really enjoying it instead of cigarettes and i stopped smoking cigarettes since i bought it but two days ago i dropped it and after that it was working well, but after i changed the coil and put a new liquid it stopped firing, i changed the coil for a new one again it started working but it stopped working 1 day after that randomly, i tried replacing the coil with a 3rd new one and it still doesnt work and i even replaced the upper part and try a new one with a new cartage still doesn't work, offcorse i charged my device and it lights up purple normally but i still got no idea why it doesnt fire or heat up, i returned to smoke again those two days because i have no device to satisfy my nicotine needs, can someone please help me asap? i have a surgery in two weeks that my doctor told me to stop smoking before the surgery.    

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Vapor Talk Forum

Vapor Talk is a worldwide retailer of electronic cigarettes, e liquids, vape mods & more! Our Store and Online Vape Forum has served over 1 million+ Users since 2008.

Locations

Vapor Talk North America
41419 Pear Street, Murrieta, CA 92562
Phone: 1-888-315-VAPOR

Vapor Talk China
Locations: Beijing, Qingdao
Phone: +88-1-400-698-2209
×
×
  • Create New...