Jump to content
Ternunda Hunter

"Wattage Mode" SMOK T-Priv

Recommended Posts

Hey there!

I've only ever had little e-cigs and prefilled tanks before.. But, I just decided to go the full mod route. I got my SMOK T-priv kit in the mail yesterday and decided to keep the Baby-Q2 coil on it. Everything was going great but lately, after just 2 pulls, the LEDs will blink and the screen will say "Wattage Mode." The only way for me to then get it to fire (it will respond to me pressing the fire button but won't actually do anything) is to go into Mode > Temp > and go through those options. 

Here's my set up:
Baby Beast Tank
Q2 coil (recommends 55-65 watts)
Ni200, .006
.4 ohms
I've tried anywhere from 35 - 60. I prefer 55. 
350f
And each regular pull for me is anywhere from 1.5s to 1.9s. 

It doesn't feel hot, the flavor is great, the coil doesn't appear burned or anything. Plenty of juice and plenty of airflow. 
Oh, and it's set to "Normal"

Thanks in advance for any help, guys. I've been trolling around on Youtube and other help sites but even the owners manual doesn't say anything about a "Wattage Mode" warning on the screen with blinking lights. In fact, it doesn't actually address blinking lights at all.

-Tern

Share this post


Link to post
Share on other sites

So, what I didn't realize (which should have been common sense) was that I was actually switching between TEMP and WATT mode, lol. So, in my noob-dom I was setting everything up in Watt mode and assumed I needed to do the same with Temp, since it was there!

I've got it all taken care of. Put it in WATT, left it there and it works like a charm. Why I thought it wasn't firing was because the mod was automatically putting it back in Watt mode for me... But the pre-set was at 6 watts because I'd never used it before. So it just felt like nothing was happening.

And I can only assume the flashing LEDs were just to get my attention because there's nothing anywhere saying frequency or amount of flashes means anything specifically. 

Thanks so much :D!

Share this post


Link to post
Share on other sites

It happens, and that is why forums such as this are here.  I like my babybeast with the .4ohm coil around 35 watts with a 70vg/30pg juice. It does change a bit depending on the flavor I am using at the time.

Share this post


Link to post
Share on other sites

You ask good questions, give good information... you'll be a pro at this in no time. You've also come to the right place. We have wonderful members who are ever-patient and helpful.   :) 

Share this post


Link to post
Share on other sites

Hey man im having the same issue with my new Tpriv

Everytime it switches to wattage mode it goes to 6.0 watts and its not firing. 

Just too see if it would fire i switched it back to temp control it did but the warning sign came up again with wattage mode.

I like this mod an i really want to quit smoking any help would be awesome. Aloha.

Share this post


Link to post
Share on other sites
11 hours ago, Pookela79 said:

Hey man im having the same issue with my new Tpriv

Everytime it switches to wattage mode it goes to 6.0 watts and its not firing. 

Just too see if it would fire i switched it back to temp control it did but the warning sign came up again with wattage mode.

I like this mod an i really want to quit smoking any help would be awesome. Aloha.

Ok so when you go into watt mode just put it on normal and leave it alone. When youre on the main display use the left and right button opposite the firing button to move the wattage up (that 6.0). It seems like it isnt firing because it is literally only at 6 watts, but it is! Justuse the right button to move the wattage up to the appropriate level for your coil.

Share this post


Link to post
Share on other sites

To quickly clarify, you don't want to go to temp and leave it on that. You'll know you entered temp mode when the display changes to a 3 digit number (default is 320 or something). Always go to watt > norm. :)

Share this post


Link to post
Share on other sites

Welcome all!  It sounds as if you may be putting the mod(s) in temp control with Smok sub ohm tanks attached e.g. baby beast, big beast, monster beast.  All of those tanks use coils that are made out of Kanthal.  Temp control will not work with Kanthal coils on a Smok device.  You mod will "toss" you back into variable wattage mode.  This is a good thing.  Variable wattage is what you want to use for these coils/tanks.  I believe you have the low power setting problem solved already.  Nice work!  My Alien tossed me back into variable wattage mode once but set the wattage for 220W when it did.  That was a bit of a surprise when all of a sudden I was vaping fire (so to speak).  There is quite a bit of information here and on the web if you want to try temp control someday.   For now enjoy!  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Vapor Talk Forum

Vapor Talk is a worldwide retailer of electronic cigarettes, e liquids, vape mods & more! Our Store and Online Vape Forum has served over 1 million+ Users since 2008.

Locations

Vapor Talk North America
41419 Pear Street, Murrieta, CA 92562
Phone: 1-888-315-VAPOR

Vapor Talk China
Locations: Beijing, Qingdao
Phone: +88-1-400-698-2209
×