Jump to content

  • Log in with Facebook Log in with Twitter      Sign In   
  • Create Account

Photo
- - - - -

Ego Batt Not Working?


  • Please log in to reply
9 replies to this topic

#1 ossiss

ossiss

    VT Member

  • VT Member
  • 13 posts
  • Location:wisconsin

Posted 16 August 2010 - 05:27 AM

got my joye ego package awhile ago, worked just fine. my battery died today, so i loaded up my extra that was charging, and i got no vapor production at all. it works fine with the other batt, but this one is just not giving me anything. ive swapped out attys, switche up cartridges, went the whole nine yards. but nothing seems to work. help?

#2 jeffb

jeffb

    I always will be awesome

  • V|T Admin
  • 7,705 posts
  • Gender:Male
  • Location:SoCal
  • Interests:Pina coladas & getting caught in the rain

Posted 16 August 2010 - 05:32 AM

Sounds like the batt is dead. Have you used this batt before?

#3 ossiss

ossiss

    VT Member

  • VT Member
  • 13 posts
  • Location:wisconsin

Posted 16 August 2010 - 05:48 AM

Sounds like the batt is dead. Have you used this batt before?


indeed. it worked just fine. light comes on and everything, but i get no vapor.

#4 jeffb

jeffb

    I always will be awesome

  • V|T Admin
  • 7,705 posts
  • Gender:Male
  • Location:SoCal
  • Interests:Pina coladas & getting caught in the rain

Posted 16 August 2010 - 05:50 AM

I've had a couple eGo batts that did that. There was enough power in the batt to turn on the button light but not enough to power an atty. Do you have access to a multimeter to test the batts power output?

#5 ossiss

ossiss

    VT Member

  • VT Member
  • 13 posts
  • Location:wisconsin

Posted 16 August 2010 - 06:24 AM

I've had a couple eGo batts that did that. There was enough power in the batt to turn on the button light but not enough to power an atty. Do you have access to a multimeter to test the batts power output?


nope. and id have no idea where to find one either.

#6 jeffb

jeffb

    I always will be awesome

  • V|T Admin
  • 7,705 posts
  • Gender:Male
  • Location:SoCal
  • Interests:Pina coladas & getting caught in the rain

Posted 16 August 2010 - 06:55 AM

Radio Shack usually carries them. No need to get a really expensive one. I've seen them as low as $3 online. There are also videos online showing how to use one. Its really easy.

#7 ossiss

ossiss

    VT Member

  • VT Member
  • 13 posts
  • Location:wisconsin

Posted 16 August 2010 - 08:01 AM

its not taking a charge when i plug it in. the light stays dim, and i can still push the button on the batt and the light glows.

#8 Jolly

Jolly

    Supreme Poster

  • e Cig Supplier
  • 823 posts
  • Gender:Male
  • Location:PA

Posted 16 August 2010 - 09:22 AM

clean your contacts with a q-tip and rubbing alcohol till there is no film left on them.
check the charger and make sure that inside it is also bright and clean. if not unplug it and try to clean it.

what i do is dip it in and then give it a good whip to take off any extra liquid any time i clean anything.
i got a dead 510 charger from someone once for tinkering with. i found that the problem was that the positive contact was so caked with old juice that it wouldn't make a connection. actually had to use a wire brush on a dremel to clean it.

#9 ossiss

ossiss

    VT Member

  • VT Member
  • 13 posts
  • Location:wisconsin

Posted 16 August 2010 - 09:41 AM

clean your contacts with a q-tip and rubbing alcohol till there is no film left on them.
check the charger and make sure that inside it is also bright and clean. if not unplug it and try to clean it.

what i do is dip it in and then give it a good whip to take off any extra liquid any time i clean anything.
i got a dead 510 charger from someone once for tinkering with. i found that the problem was that the positive contact was so caked with old juice that it wouldn't make a connection. actually had to use a wire brush on a dremel to clean it.


did just that. doesnt seem to have worked. im letting it "charge" (if it can) and let it do that for now.

#10 snubber

snubber

    Vapor Talk Respected Member

  • VIP Member
  • 1,317 posts
  • Gender:Male
  • Location:Annapolis,Maryland USA
  • Interests:grandkids,fishing,golf, nascar,video games,vaping

Posted 16 August 2010 - 05:09 PM

How long have you had it and where did you get it? It may be under some kind of warranty.