Jump to content

Your cart is empty!
View Cart Checkout
Cart subtotal: $0.00
Welcome to Vapor Talk E Cig Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

Ego Led Constantly Flashing?

- - - - -

  • Please log in to reply
12 replies to this topic

#1
FTJoe

FTJoe

    Vapor Talk Veteran

  • VIP Member
  • 2,228 posts
  • Gender:Male
My relatively new ego is flashing constantly. Was periodic, now going all the time. It ran out of Juice last night, so charged it overnight and it seemed fine. Now just flashing. Trippy, still works but I guess there's an issue of some kind. Have to see if I can figure out when I got it and from whom. Any ideas what this means? Stops when I throw it on the charger, doesn't happen when it off but then does start up again.

Edited by FTJoe, 18 July 2010 - 08:46 AM.


#2
Burn

Burn

    Insane Poster

  • VIP Member
  • 520 posts
  • Gender:Male
  • Location:127.0.0.1

My relatively new ego is flashing constantly. Was periodic, now going all the time. It ran out of Juice last night, so charged it overnight and it seemed fine. Now just flashing. Trippy, still works but I guess there's an issue of some kind. Have to see if I can figure out when I got it and from whom. Any ideas what this means? Stops when I throw it on the charger, doesn't happen when it off but then does start up again.


I cant find an article I read about this a few months ago. If I recall correctly, the issue is with the sensor that measures current voltage. I believe the correction was that you ran it all the way down (which it really isnt, charge it for 10 minutes so it will turn on again and then drain that down as far as you can. Apparently this "calibrates" the chip that controls the low voltage.

Someone may come along with a stronger recollection that I have but I know I have read about this before regarding the ego.

#3
FTJoe

FTJoe

    Vapor Talk Veteran

  • VIP Member
  • 2,228 posts
  • Gender:Male
Okay - I'll give it a whirl, besides, I'm not positive where I got it anyway. I guess the LED flashing will help run it down as well.

Ummm - it's actually going on and off so I can't use it, atty is going on for each pulse.

Edited by FTJoe, 18 July 2010 - 09:12 AM.


#4
Burn

Burn

    Insane Poster

  • VIP Member
  • 520 posts
  • Gender:Male
  • Location:127.0.0.1

Okay - I'll give it a whirl, besides, I'm not positive where I got it anyway. I guess the LED flashing will help run it down as well.

Ummm - it's actually going on and off so I can't use it, atty is going on for each pulse.


just for g&g, did you try another atty? just to remove that variable, if nothing else?

#5
Bigjim

Bigjim

    Super Poster

  • VT Member
  • 299 posts
  • Gender:Male
  • Location:Macomb, MI
  • Interests:Family, Biking, Gaming, Music, Fishing and Vaping!
I was having the same problem Joe. I tossed in into the graveyard bowl and just bought a new one. Now that it's finally done flashing, after about a week, I'm gonna plug it in and see what happens...

#6
FTJoe

FTJoe

    Vapor Talk Veteran

  • VIP Member
  • 2,228 posts
  • Gender:Male
I'll let you know how I make out, stopped flashing so I through it on the fast charger. Now I'm wondering if trickle is better. Update us either way please.

#7
Bigjim

Bigjim

    Super Poster

  • VT Member
  • 299 posts
  • Gender:Male
  • Location:Macomb, MI
  • Interests:Family, Biking, Gaming, Music, Fishing and Vaping!
Ok, as soon as the battery touched the charger, the ego's led flashed 3 times and stopped. I screwed it in all the way and it flashed 3 more. The charger light remained green. I took the battery off and tried it again... same thing. Back to the Grave Yard bowl...

#8
FTJoe

FTJoe

    Vapor Talk Veteran

  • VIP Member
  • 2,228 posts
  • Gender:Male
Mine still messed up, good thing I charged up the gift card...

#9
nana

nana

    Vapor Talk God Poster

  • VIP Member
  • 3,322 posts
  • Gender:Female
  • Location:USA
I have 6 ego/tornado batts and have never had that happen. My oldest batts are 6 months, the others are about 4 months. Although they aren't holding a charge as long anymore, they only flash when they need a charge.

#10
Bigjim

Bigjim

    Super Poster

  • VT Member
  • 299 posts
  • Gender:Male
  • Location:Macomb, MI
  • Interests:Family, Biking, Gaming, Music, Fishing and Vaping!
LoL, I hear ya Joe! Not sure whats going on with these batteries, but I can't complain after a few months of solid use. So far, I have a dead atty, a couple stinky atty's and a weird ego battery sittin' in the grave yard. As soon as I get a few more wacky/dead things, I'm sending them out to whomever it was that was looking for experimental items. I can't seem to find that post, was it Jolly? Let me know who that was so I can rename the Grave-yard to the "_____Bowl"!